Si vous souhaitez appliquer la même mise en forme conditionnelle à plusieurs ou à toutes les cellules d’Excel, vous devez avant tout tenir compte d’une chose : Cellule mise en forme conditionnelle. Lisez ici ce qui est important.

Pour appliquer la mise en forme conditionnelle à plusieurs cellules d’une même ligne, procédez comme suit

Supposons que vous ayez un simple tableau contenant les heures de travail quotidiennes de trois employés. Vous souhaitez voir rapidement, en coloriant chaque ligne, les jours où les personnes ont travaillé moins de 20 heures au total.

Exemple de liste d’heures de travail

Dans l’exemple, sélectionne la zone de A2 à D8. Il s’agit de toutes les cellules qui doivent être affichées en couleur si la limite d’heures définie n’est pas atteinte.

Cliquez sur l’icône Mise en forme conditionnelle dans le ruban Démarrer.

Sélectionnez l’option Nouvelle règle.

Sous Windows, indiquez ensuite comme type de règle : Utiliser une formule pour déterminer les cellules à formater. Sur un Mac, choisissez auparavant Style : Classique.

Saisissez =SOMME($B2:$D2)20 comme formule.

La formule pour la mise en forme conditionnelle ligne par ligne

Pour la mise en forme, choisissez une méthode pour faire ressortir ces cellules de manière appropriée à votre cas d’utilisation. Ici, nous avons choisi de colorer le fond en bleu.

Le résultat peut alors ressembler par exemple à ceci

En relation  Excel : le travail avec la fonction de filtre d'Excel 365 est aussi simple que cela.

C’est la particularité du formatage ligne par ligne

Les signes du dollar devant les adresses de colonne dans la formule de mise en forme sont essentiels pour que le formatage agisse vraiment de manière uniforme sur toute la ligne. Cela est lié à la manière dont Excel utilise les références de cellules dans la formule pour la zone sélectionnée. Car – comme lors de la copie de cellules – Excel essaie ici d’adapter les adresses de cellules utilisées pour toutes les cellules à droite et en dessous de la “cellule de départ” B2.

Sans le signe dollar, Excel n’utiliserait par exemple plus la plage B2 à D2 pour déterminer la condition de formatage de la cellule C2, mais ferait tout glisser d’une cellule vers la droite, c’est-à-dire qu’il ferait la somme de C2 à E2. Le signe du dollar empêche cette adaptation indésirable.

L’adaptation dans le sens vertical est en revanche souhaitable. En effet, pour la question concernant le marquage de la deuxième balise, vous souhaitez que la somme soit calculée sur la plage B3 à D3 correspondante. En revanche, si vous utilisiez ici aussi des signes du dollar, c’est-à-dire si vous utilisiez pour la formule de formatage =SOMME($B$2:$D$2)20, seuls les chiffres de la ligne 2 seraient évalués dans l’ensemble de la plage, c’est-à-dire que toutes les lignes apparaîtraient colorées ou non, en fonction du contenu.

Pour adapter le principe de mise en forme par colonne

Si vous souhaitez mettre en évidence visuellement une colonne entière ou au moins une plage de cellules verticales lorsqu’une condition particulière est remplie, il vous suffit de modifier la position du signe dollar dans la formule de condition. Il appartient alors à la deuxième partie des adresses de cellules.

En relation  Les bases d'Excel : trouver des cellules, additionner des nombres, faire une moyenne.

Par exemple, pour déterminer quel employé de l’exemple ci-dessus a travaillé moins de 50 heures au total, cette formule de mise en forme serait utile : =SOMME(B$2:B$8)50