Si tu souhaites mettre en évidence les événements à venir dans Excel, un fond de couleur gradué est pratique. Jours date à date. Les événements les plus urgents sont ainsi mis en évidence. Lisez ici comment vous pouvez facilement intégrer cela dans votre liste de rendez-vous.

Comment déterminer les jours jusqu’à chaque date

Examinez la liste simple suivante. Différentes valeurs de date sont inscrites dans la colonne A.

C’est le point de départ de votre liste de rendez-vous.

Dans la colonne B, créez une cellule à côté de chaque date pour déterminer le nombre de jours restants jusqu’à la date en question. C’est un bon point de départ pour le marquage en couleur.

Il faut donc calculer la différence entre la date inscrite et la date d’aujourd’hui, pour cela, écrivez la formule suivante dans le champ B2 : =A2-HEUTE()

Au lieu d’un nombre, vous obtiendrez cependant une date en 1900, car Excel reformate automatiquement le champ B2 en date.

Pour changer cela, changez le formatage de la date en standard dans la barre de menu. Vous voyez maintenant la différence souhaitée en jours.

Copiez la formule et le formatage dans les cellules en dessous de B2 en faisant glisser le petit carré dans le cadre de la cellule de B2 vers le bas.

La liste a été complétée par une colonne pour les jours jusqu’à la date mentionnée.

En relation  Voici comment calculer le nombre de jours restants avant une date.

Vous obtenez maintenant la liste des jours jusqu’à l’échéance concernée. Les chiffres négatifs signifient qu’il est en retard : Date jours fériés 2021. Pour un rendez-vous déjà clôturé, cet affichage d’un temps restant négatif n’est évidemment pas très esthétique. C’est pourquoi vous le désactivez à l’étape suivante.

Pour marquer un rendez-vous comme terminé

La colonne C doit porter des mentions pour les rendez-vous terminés : (Date jours fériés 2022). Pour qu’une entrée ici ait un effet sur l’affichage du reste dans la colonne B, vous complétez la formule avec une distinction de cas : Si C2 est vide, le temps restant est calculé comme précédemment, une mention dans la colonne C désactive l’affichage des jours restants.

Modifiez la formule en B2 de la façon suivante : =SI(C2=””;A2-HEUTE() ;””)

Essayez d’écrire “terminé” ou “ok” dans C2. Date jours fériés 2023. La cellule B2 ne devrait plus recevoir de valeur numérique, mais être vide.

Maintenant, cliquez à nouveau avec la souris sur le petit carré en bas à droite de la cellule B2 sélectionnée et faites-le glisser jusqu’à la dernière ligne de la liste pour multiplier la formule modifiée.

La liste a maintenant la possibilité d’enregistrer une note pour les rendez-vous terminés,

Pour mettre en évidence les rendez-vous à venir

Sélectionnez maintenant les cellules avec des valeurs dans la colonne des jours restants, c’est-à-dire B2 à B7.

Allez au bouton Mise en forme conditionnelle et sélectionnez la toute première entrée dans Échelles de couleurs.

La colonne B est maintenant déjà colorée, mais sur une base de calcul erronée : Date jours rallongent. En effet, Excel divise par défaut la liste des valeurs des jours restants en minimum et maximum et veille à une répartition uniforme des couleurs – mais vous pouvez améliorer cela en créant votre propre règle de coloration.

En relation  Excel vous rappelle chaque anniversaire à venir.

D’ailleurs, si vous le souhaitez, vous pouvez également inclure la semaine calendaire correspondante dans vos tableaux.

Pour définir des règles individuelles de coloration, procédez comme suit

En général, vous avez d’autres souhaits, par exemple que tout ce qui est dû aujourd’hui soit rouge. Le jaune est destiné aux rendez-vous qui doivent avoir lieu dans 3 jours tout ce qui est prévu dans 14 jours ou plus se présente en vert inoffensif : (Jour date de naissance). Vous communiquez maintenant cette règle à Excel :

Pour cela, laissez B2 à B7 sélectionnés et allez dans Mise en forme conditionnelle sur l’entrée Gérer les règles.

Vous devriez maintenant voir un aperçu des règles, qui se compose d’une seule entrée pour la règle créée précédemment : Jour date excel. Double-cliquez sur cette entrée pour la modifier.

Modifiez les valeurs dans les six champs de saisie comme suit pour obtenir la coloration souhaitée :

Cette règle permet de mettre en évidence les rendez-vous à venir.

Si vous confirmez la modification de la règle de mise en forme et fermez la fenêtre de gestion, Excel devrait mettre les dates en couleur comme vous le souhaitez :

Vous voyez maintenant, grâce au marquage en couleur, ce qui est dû prochainement.

Comment calculer les jours ouvrables

En raison du calcul de la date dans la formule ci-dessus, le tableau ne tient pas compte des week-ends : Jour date php. Si, dans votre cas, il s’agit par exemple de terminer des projets, ces chiffres ne vous seront donc pas d’une grande aide, mais vous aurez besoin des jours de travail effectifs jusqu’au jour de référence.

En relation  Comment utiliser la mise en forme conditionnelle avec une liste de valeurs dans Excel ?

Ce n’est pas un problème dans Excel. Jour date vba. Vous devez simplement utiliser une autre méthode pour calculer la différence de date : Jours date calcul. Utilisez la fonction Jours ouvrables nets() pour calculer en jours ouvrables purs.

Voici la nouvelle formule complète pour la cellule B2 : =SI(C2=””;JOURS NETS DE TRAVAIL(AUJOURD’HUI();A2) ;””)

Recopiez ensuite les formules en faisant glisser le carré vers le bas pour remplacer la première version du calcul.

La méthode est similaire à celle de l’astuce Comment déterminer qui a son anniversaire aujourd’hui dans une liste de personnes Excel. Mais à la différence de la liste d’anniversaires, les dates ne reviennent pas chaque année.

Vous pouvez également télécharger l’exemple prêt à l’emploi.